Lancia Beta Forum
October 31, 2020, 10:45:04 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: 2020 events calendar filling up nicely
http://www.betaboyz.myzen.co.uk/forum/index.php?board=88.0
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: Crap Carb Revisited - Auto Choke  (Read 1656 times)
0 Members and 1 Guest are viewing this topic.
tonylanciabeta
Guest
« on: November 30, 2008, 06:49:10 PM »



From: Pete_d  (Original Message)   Sent: 21/05/2007 21:18
I've got an intermittent problem with the automatic choke on my 79 2000 Coupe. From cold it seems Ok, fast idles for a few mins then drops back to normal idle (bit slow for a while but then comes up to 900ish rpm). When its up to full temp the idle is all over the place, sometimes its at normal speed but sometimes it'll be at 2000rpm, a dab on the throttle brings it back down. The car runs at normal temperature and there is a proper coolant level in the expansion tank. Anyone have any ideas?




From: A1-6HPE   Sent: 23/05/2007 18:42
Hello pete_d,
Sounds to me like the small coil spring inside the mechanism has broken. You can remake the end by uncoiling it. This spring pulls the two rotating bits together When you disassemble the choke, make a clear mark so that you can orientate it properly later.
Is the water chamber getting hot (ie is there coolant circulating in to it)?


Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!