Lancia Beta Forum
April 18, 2024, 03:16:24 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Looking for Lancia Beta parts: www.lanciabetaparts.co.uk
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: Oil sensors and switches  (Read 529 times)
0 Members and 1 Guest are viewing this topic.
JohnFol
Hero Member
*****
Offline Offline

United Kingdom United Kingdom

Posts: 346



« on: February 23, 2024, 04:42:24 PM »

Afternoon all, just want to double check a few things as my oil temperature gauge is not working

On my dashboard (pic 2) I have :
6. Engine oil low pressure warning light
7. Oil pressure gauge.
11. Oil temperature gauge.

Around the oil filter (pic 1) I have:
2. Oil pressure transmitter (guessing this links to 7. Oil pressure gauge)
6. Oil pressure switch (guessing this links to 6. Engine oil low pressure warning light)
If that's correct, where is the oil temperature sensor?

Haynes (that font of truth) has the following
Oil Pressure Switch...Blue.
Oil Temperature Sender...Yellow/Black.
Oil Pressure Sender...Grey/Red.
Fairly sure I may have some of these wrong way round Sad










* Oil schematic.png (24.48 KB, 341x239 - viewed 119 times.)

* Dashboard Comp.jpg (542.2 KB, 2632x2920 - viewed 121 times.)
Logged
peteracs
Administrator
Legendary Member
******
Offline Offline

United Kingdom United Kingdom

Posts: 3834


Peter Stokes


« Reply #1 on: February 23, 2024, 06:46:38 PM »

Hi John

 Nos 12 in you diagram?

Peter
Logged

Beta Spyder S2 pre F/L 1600
Beta HPE S2 pre F/L 1600
Nigel
Hero Member
*****
Offline Offline

United Kingdom United Kingdom

Posts: 870



« Reply #2 on: February 25, 2024, 02:10:59 PM »

Hi John,
My Lancia diagram shows Yellow (G) from the Oil temp sender all
the way to the dash. This yellow wire goes through at least 2 connectors en-route.

On the dash connector it appears to be the right-hand plug,
and is in 'number 2' position, from which side I'm not sure.




* enginesensorsdiagram_resized.jpg (1332.36 KB, 3000x2250 - viewed 98 times.)
Logged

1984 2.0 Carb HPE [ex Aus] Grigio Finanza.
2007 Mazda 6 2.3 [current daily, highly recommended]
The past:
1980 2.0 HPE White in South Africa [hope it survives!]
1976 1.6 Coupe Lancia Blu [PFG 76R] [probably deceased]
oh,and an Uno Turbo 1997 also in SA [stolen,never recovered]
JohnFol
Hero Member
*****
Offline Offline

United Kingdom United Kingdom

Posts: 346



« Reply #3 on: February 26, 2024, 10:23:53 AM »

Hi John

 Nos 12 in you diagram?

Peter

I thought I was going mad when I saw your obvious answer. I took the image from a bigger picture, and to recover some credibility, it shows the oil temp labelled 6 not 12.... but in top right, it's different..


* Oil2.png (162.25 KB, 822x560 - viewed 92 times.)
Logged
JohnFol
Hero Member
*****
Offline Offline

United Kingdom United Kingdom

Posts: 346



« Reply #4 on: February 26, 2024, 11:04:13 AM »

Nigel, thanks for confirming the colours. Found 2 of mine were swapped  Cry
Logged
peteracs
Administrator
Legendary Member
******
Offline Offline

United Kingdom United Kingdom

Posts: 3834


Peter Stokes


« Reply #5 on: February 27, 2024, 12:18:03 AM »

Hi John

Interesting the main picture only shows two sensors, wonder what engine that is from?

Peter
Logged

Beta Spyder S2 pre F/L 1600
Beta HPE S2 pre F/L 1600
squiglyzigly
Hero Member
*****
Offline Offline

United Kingdom United Kingdom

Posts: 517



« Reply #6 on: February 27, 2024, 08:14:17 AM »

Hi Peter,
My S2 Berlina 2000 only has oil pressure warning light and oil pressure gauge on the dashboard. No oil temp.

Cheers
Ian
Logged

VX HPE (resto started Sept ‘21)
Beta Saloon 2.0l s2 1979 (completed July 2020)
Beta coupé VX (completed April 2017)
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!