Lancia Beta Forum
October 14, 2019, 11:03:57 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Lancia Beta Forum NEC Club Stand 2019
http://www.betaboyz.myzen.co.uk/forum/index.php?topic=3898.0
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: Tips  (Read 3006 times)
0 Members and 1 Guest are viewing this topic.
tonylanciabeta
Guest
« on: November 01, 2008, 03:32:32 PM »

 

From AlecD.
Wipers too slow-
Try replacing its fuse as old ones can change their resistance.



Bad earths- Replace the spider connector below the headlight mounts with one similar to the one used behind the dash. Keep it clean!





Heater fan- If you turn on your heater and it causes the dash lights to turn off, a loose fuse                                                                       could have caused the the plastic body of the fuse to melt.





Indicators running too fast.   

From Markwast. Firstly check that all are the bulbs are working. If one isn't then check the earths. Once they are clean but there is still a bulb not working, dismantle each block connector and clean each spade terminal. Once i had done this all my indiactor faults were cured    and i have had no further problems.






Gear Linkage

From Markwast - When installing a new linkage bush set, before you install the metal pivots, soften the bushes in boiling water. Do this also when pushing them into place on the linkage arms.




Door Car Clips

From TonyLanciaBeta - If you want new clips for your door cards etc, Tony got some Delta ones from his local Fiat dealer and they fit really well and dont damage the cards.




Keys- From Tony Brown - Need a set of keys = including that high security one for the door/boot locks? I can recommend John Richard of Keys Unlimited. He not only supplies the blanks but will cut the keys to a supplied code as well. Fast response and good prices. 0151 342 2318/4074.



Another quick tip I have come across during my restoration.

I was getting terrible noise and vibration that turned out to be the engine shock absorber. When I took it off, luckily the damper itself was still ok (not seized or slack) but the rubber bush at the lower end was completely shot so effectively, the damper rod was just banging against the mounting bolt all the time.

A couple of measurements showed that I needed a bush with an OD of 25mm and ID of 10mm.

A trip to my local classic car spares shop provided me with a Triumph Spitfire rear spring eye bush at a cost of 5.30.
This is too long and needs to be cut down and has a diameter which is fractionally too big (no metric fittings on the Spitfire) but 10 mins with a file and it was a perfect fit.

I pressed the bush into the damper lower eye in the vice after removing the old outer sleeve with a hacksaw and the car is a completely different beast. Smooth and quiet(ish).

I hope this might help somebody and it is certainly a lot easier than trying to find a replacement damper.

Cheers.
Ian.


« Last Edit: November 30, 2008, 07:13:48 PM by tonylanciabeta » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!