Lancia Beta Forum
December 19, 2018, 05:53:16 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Looking for Lancia Beta Parts
Lots of new items recently added
see: www.lanciabetaparts.co.uk
 
   Home   Help Contact Admin Search Calendar Gallery Donations Articles Login Register  
Pages: [1]
  Print  
Author Topic: Fuel Pump Issues  (Read 187 times)
0 Members and 1 Guest are viewing this topic.
Sloany
Jr. Member
**
Offline Offline

United Kingdom United Kingdom

Posts: 26


« on: September 19, 2018, 12:38:30 PM »

Hi,

I have a 78 series 2 spider.
I have fitted a new mechanical fuel pump, from Beta Boys, and had the car running.
However now the pump will not pump fuel.
I have primed all the lines using a vac pump, and removed the pump checking it manually and it is pumping.
I noticed there is no spacer fitted between the pump and the motor, could this be the issue? When I fitted the pump I cannot recall a spacer but may have dropped out during my fault diagnosis at some point and been misplaced.
Any help appreciated

Thanks Garry
Logged
peteracs
Administrator
Legendary Member
******
Offline Offline

United Kingdom United Kingdom

Posts: 1777



« Reply #1 on: September 19, 2018, 05:45:24 PM »

Any chance you have a blockage due to crap in the tank/filter? A very common problem.

Peter
Logged

Beta Spyder S2 pre F/L 1600
Saab 9-3 1.9Tid Cabrio
Sloany
Jr. Member
**
Offline Offline

United Kingdom United Kingdom

Posts: 26


« Reply #2 on: September 19, 2018, 06:03:09 PM »

No, I have a good flow from the tank with a hand held vac pump with little vacuum.
I think it must be the missing spacer, this would mean the pump actuator arm is not in the correct position?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!