Lancia Beta Forum
October 19, 2017, 06:33:40 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: 2017 Events Calendar
http://www.betaboyz.myzen.co.uk/forum/index.php?board=85.0
 
   Home   Help Contact Admin Search Calendar Gallery Donations Articles Login Register  
Pages: [1]
  Print  
Author Topic: No parking or dash lights  (Read 175 times)
0 Members and 1 Guest are viewing this topic.
droptop
Hero Member
*****
Offline Offline

Ireland, Republic of Ireland, Republic of

Posts: 681



« on: June 05, 2017, 09:31:05 AM »

The parking and dash lights on my '79 spyder don't work
Dip and main beams work without the ignition being on just like my pre face-lift '78
The thing is that I don't know if they ever worked as I've never driven the car
Any suggestions where to begin checking?
 Huh?
Logged

Rust never sleeps
squiglyzigly
Jr. Member
**
Offline Offline

United Kingdom United Kingdom

Posts: 46



« Reply #1 on: July 17, 2017, 08:27:08 PM »

Do you get the green lamp illuminated on the dash when you switch the parking light on (I presume you are referring to the side light in the front indicator assembly)?  You may have 2 separate unrelated faults. First find the fuse for the parking lights and check with a meter there is voltage both sides of the fuse. I had numerous old fuses that were not clean enough to conduct. Try checking voltage at the connector to the parking lights under the bonnet behind the bumper. Try pushing in/wiggling all the connectors in the underside of the fuse box. 
Its a start but the chase can go on some way further if the fault is not there.
Logged

Beta coupé VX (completed April 2017)
Aprilia RSVR 2002
Aprilia Tuono R (130 rear wheel BHP)
Alfa 159 sportwagon
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!