Lancia Beta Forum
August 24, 2019, 01:13:42 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Beta Forum Key rings and car stickers now available here : www.lanciabetaforumshop.co.uk/
With all profits going to the forum, many thanks to Mark @ www.lanciabetaparts.co.uk
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: Indicator problem  (Read 2328 times)
0 Members and 1 Guest are viewing this topic.
Oldbones
Jr. Member
**
Offline Offline

Posts: 29


« on: July 05, 2013, 05:38:35 PM »

Can anyone help  Huh?

1975 beta spyder

My right turn indicators are not flashing but the Left turn are perfect. I am fed up of only turning left as going around in circles  Grin

I have continuity at my front and rear indicator bulb holder earths, but what i think seem odd is that i also have continuity from my live wires to earth. I thought wrong but this is also the case for the working left turn live wires so now am totally puzzled.

When I turn on my right indicator my alternator warning light glows in the same flashing sequence as the indicator on the dash

Should I be seeing continuity from live to earth
Can anyone advise what I should check. Please keep any instructions simple as my electrical knowledge is basic
.

Thank you

John
« Last Edit: July 05, 2013, 07:46:45 PM by Oldbones » Logged
gengis
Sr. Member
****
Offline Offline

Posts: 147


« Reply #1 on: July 05, 2013, 10:35:25 PM »

When the right indicator is on...does the click frequency of the flasher unit increase?  If so there is an open circuit on the right hand circuit.  It may be front, rear, or side repeater or all three in which case it could be the right hand wiring or flasher unit

For the tests you done so far, the continuity test is good for checking earthing and wiring, but when your going across the live indicator feed and earth you will be measuring a component ie: any of the bulbs that are still connected, or components in the flasher unit.  best to measure volts d.c. when looking for the feed wire.
Logged

1983 - Lancia Beta Coupe
1982 - Fiat 124 Spider
2012 - Alfa Romeo Mito
2011 - Fiat Fiorino
2006 - BMW F800st
Oldbones
Jr. Member
**
Offline Offline

Posts: 29


« Reply #2 on: July 06, 2013, 05:02:28 PM »

Thank for your explanation I think I understand so far! To answer your question yes it does flash faster and the needle on the battery condition scale waves in time to the flasher also the alternator wangling light glows on and off.

Can you please explain what you mean by open circuit? Do you mean a broken wire or a connection has become disconnected? All wires seem to be connected but I have not checked the hazard warning light circuit as yet could this be worth checking?

Thanks for your help

Frustrated

John with sunshine but a in mot'd spyder
« Last Edit: July 06, 2013, 11:38:11 PM by Oldbones » Logged
gengis
Sr. Member
****
Offline Offline

Posts: 147


« Reply #3 on: July 07, 2013, 12:31:17 AM »

Hi,

Ignore the alternator warning lamp for the time being...characteristic of the Beta!

Open Circuit...yep you got it, a broken wire, a blown bulb, or component failure.

If we assume that all bulbs are healthy, and the earth return from these bulbs are healthy, and we know that the flasher unit is receiving a signal from the stalk switch.  Our attention must focus on the flasher unit or the hazard switch or wherever the right hand circuit starts it's life.  Does the hazard switch work the right hand lights?  I'll have a look at the diagram tomorrow to gain some info.

John.
Logged

1983 - Lancia Beta Coupe
1982 - Fiat 124 Spider
2012 - Alfa Romeo Mito
2011 - Fiat Fiorino
2006 - BMW F800st
Oldbones
Jr. Member
**
Offline Offline

Posts: 29


« Reply #4 on: July 07, 2013, 09:52:06 AM »

No the hazards don't work at all but presumed once the indicator was fixed the hazards would automatically work
Logged
Oldbones
Jr. Member
**
Offline Offline

Posts: 29


« Reply #5 on: July 07, 2013, 10:08:52 AM »

Correction just checked again and left is working when hazards switched on but flash rate is too fast

Cheers
John
Logged
gengis
Sr. Member
****
Offline Offline

Posts: 147


« Reply #6 on: July 08, 2013, 09:53:22 PM »

Had a quick look at a diagram tonight, and it looks like the left and right circuits start at the stalk switch, so the flasher unit is before the stalk. 

The colour of the wires at the stalk would be.
White...switched feed from flasher unit.
Blue...right hand circuit.
Blue/Black...left hand circuit.

So, your starting point would be the stalk.  Checking for volts on the blue wire would confirm the integrity of the stalk switch, then following that wire through it's connections.  I would think your fault would be close to the loom under the dash...bad connection across a multi-plug or the stalk switch itself.

Best of luck.

John.
Logged

1983 - Lancia Beta Coupe
1982 - Fiat 124 Spider
2012 - Alfa Romeo Mito
2011 - Fiat Fiorino
2006 - BMW F800st
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!