Lancia Beta Forum
August 14, 2022, 12:49:38 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Beta Meeta 50th Anniversary 2022 Bookings now open
https://www.betaboyz.myzen.co.uk/forum/index.php?topic=4385.0
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: 2000 ie Progress - Peskey Exhaust Stops Play.  (Read 1842 times)
0 Members and 1 Guest are viewing this topic.
Tony B
Full Member
***
Offline Offline

Posts: 95


« on: July 01, 2012, 09:20:48 PM »

So she's running!

Fitted the water Rail (pipe), new stat, new connecting pipes and water pump. No leaks or weeps - great. Emptied the system, refilled with anti freeze mix and then got her up to temp. I'd changed the plugs whilst the rail was off and so the oil (20 years old) and the filter was next - talk about overdue.  Shocked Oddly I'd added a bit of STP additive to the two gallons of best I'd put in and the pumps noisy again (very) and she seems to be running very rich and hunting slightly, tick over on the slow side and so I adjusted and it seemed marginally better. Slight 'sponge' on the pedal first press so I'm gonna' bleed all round again and see how we are. Catch 22 really, I can't go far yet because of MOT but need to run because of the (hopefully) impending MOT - figures.... All lights are working fine and even managed to repair the washer bottle - I've seen tougher egg shells than the petrified plastic it's made from. Certainly getting there slowly.

Annoyingly the back box decided to 'hole'  - must have been the heat and it was poor anyway! Does anyone know where I can get one without the need to ring Bob Diamond?? Any help would be appreciated Smiley
Logged
MattNoVAT
Administrator
Legendary Member
******
Offline Offline

France France

Posts: 1830



« Reply #1 on: July 01, 2012, 11:05:21 PM »

Glad to hear your making good progress with the recommissioning Tony.

Maybe she needs a good run to blow the cobwebs out?  I find lack of use can make the idle a bit erratic.  Getting a few hours of driving in and then bleeding the brakes again should get the last of the air out.

I have a coupe 2000ie  back box in the garage.  I will check it tomorrow but am pretty sure it's in good condition.

Will let you know tomorrow evening.
Logged

1981 2000 Coupe S2/FL
1976 1600 Coupe S1
2007 Ypsilon 1.3 Bi-Colori
Tony B
Full Member
***
Offline Offline

Posts: 95


« Reply #2 on: July 02, 2012, 08:46:55 PM »

Hiya Matt,

Many thanks - what are we gonna' do when you leave Blighty Embarrassed Do please let me know Mate, found a couple of loose clips on the air intake but also  Grin realised the vac pipe from the ignition ECU was off - doh!! Runs sooooooo much better now!! Good (but obvious) spot me thinks!!

Onwards!  Cool
Logged
MattNoVAT
Administrator
Legendary Member
******
Offline Offline

France France

Posts: 1830



« Reply #3 on: July 02, 2012, 09:37:21 PM »

Hi Tony,

Have dug out the exhaust and checked it over, the tailpipe is fine, the main silencer section has paint that has flaked off and very light surface rust, there are no perforations to the metal itself, I've not found any blistering and I've checked the weld around the points where the pipes meet the silencer.  The curved section that joins the centre box has a wee bit of surface rust in a couple of places but I've given it a thump with a big screwdriver to see if the metal is weak and I cannot find any iffy spots.  I have photographed the end so that you can check the fitment as it is not the slide over sleeve fit, (not sure what this fitment is called - someone enlighten me?) Swivel / Ball fit ?

A good going over with a wire brush and a lick of paint and I reckon it'd do the job nicely.

I'll drop you a PM



* IMG_0182.jpg (141.92 KB, 612x816 - viewed 287 times.)

* IMG_0183.jpg (138.7 KB, 612x816 - viewed 301 times.)
Logged

1981 2000 Coupe S2/FL
1976 1600 Coupe S1
2007 Ypsilon 1.3 Bi-Colori
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!