Lancia Beta Forum
September 24, 2020, 01:19:22 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: BetaMeeta20 12th September 2020
http://www.betaboyz.myzen.co.uk/forum/index.php?topic=4080.0
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: LED Indicator Side Repeaters.  (Read 1303 times)
0 Members and 1 Guest are viewing this topic.
Neil-yaj396
Legendary Member
******
Offline Offline

Posts: 1562


1979 1300 Coupe


« on: May 07, 2012, 01:38:29 PM »

Subject to my annual struggle to get these working for the MOT (detailed elsewhere) I decided that an experiment was called for. I ordered some pre wired LED bulbs from Hong Kong. They seemed a bit steep at 1.99, but of course when they arrived that was for ten!

The only initial flaw in my plan was that the wires on the bulbs are very thin, necessitating soldering on the smallest spade terminals that I could find. These enabled me to connect the bulbs to some new looms that I'd made up. The tiny connections were then protected with electrical tape and some plastic ducting. The latter also holds the bulb in place when it is pushed into the lens, although if your original rubber cover is still intact this would probably be better.

It all works pretty well on first fit. The LED's are much brighter than the old bulbs, but they are a bit 'directional'. Only time will tell if this is a durable fix. Pictures of the process are attached. I'm happy to post out LEDs to any members that want to give it a try (I have 18!).



* 019.jpg (362.26 KB, 2048x1536 - viewed 322 times.)

* 020.jpg (121.78 KB, 1792x1344 - viewed 326 times.)

* 024.jpg (163.95 KB, 2048x1536 - viewed 322 times.)
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!