Lancia Beta Forum
December 08, 2019, 04:48:17 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Beta Forum Key rings and car stickers now available here : www.lanciabetaforumshop.co.uk/
With all profits going to the forum, many thanks to Mark @ www.lanciabetaparts.co.uk
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: HPE Front cross member  (Read 1354 times)
0 Members and 1 Guest are viewing this topic.
tonylanciabeta
Guest
« on: December 21, 2008, 09:50:05 PM »

From: glovebeast  (Original Message)   Sent: 05/11/2008

Just been informed I have some serious rot in the front cross member of my HPE. Is this a common area for rust? Are new panels available (I think I can guess the answer to that, but you never know). Anyone know of a good used one?
Cheers
Steve



From: hutch6610   Sent: 06/11/2008

It most certainly is a common rust area - they usually rot out around the sub frame bolts.
You guessed right on the next question, you have to patch but it depends on how extensive the rust is.

If its just around the captive nuts it certainly is possible.

Cannot help you with a good second hand one - anybody else got one?





From: Markwast   Sent: 06/11/2008

Hi there, i have repaired this a few times now, my hpe was almost non existant around the bottom surfaces . You will need the areas around the subframe mounting point to be in reasonable condition. Send me some pics and ill see if its any worse than what i had. betaboyz@msn.com . Just done the same repair on my Beta Saloon too.
 
Mark

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!