Lancia Beta Forum
June 29, 2022, 10:13:27 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Beta Meeta 50th Anniversary 2022 Bookings now open
https://www.betaboyz.myzen.co.uk/forum/index.php?topic=4385.0
 
   Home   Help Contact Admin Search Calendar Gallery Articles Login Register  
Pages: [1]
  Print  
Author Topic: Wiper Relay  (Read 1597 times)
0 Members and 1 Guest are viewing this topic.
tonylanciabeta
Guest
« on: December 10, 2008, 10:49:41 PM »

From: psi101  (Original Message)   Sent: 28/04/2008 10:44

HI
I have a 79 Beta Spyder and the wipers have suddenley stopped working.
Is there a fuse or relay that I should try and change before looking to see if motor is faulty?
Thanks
Simon



From: hutch6610   Sent: 28/04/2008 20:46

No specific wiper relay as such to talk about.
You have an intermittent wipe relay (small tin thing under the dash on the steering column) but this would not cause the wipers to stop - intermittent setting only.
Best thing to do is check out all the fuses in the fuse box and perhaps swap the white relays around to see if any are the cause (Relays power a number of sub systems) and i think you would notice a few other things not working!
If they check out ok and the fuses are sound, then check the four plugs into the bottom of the fuse box.
Then it just leaves the connections to the wiper motor (can corrode)
Wiper column switch or the wiper motor itself.
Probe the wiper motor with power from the battery itself but be careful you don't short out on the earth - Haynes manual is very useful for this.
Sorry i can be more specific - no single cause of wiper failure.


Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SMFAds for Free Forums
Valid XHTML 1.0! Valid CSS!