Lancia Beta Forum

Technical stuff => Fuel System Carb => Topic started by: Aussie_Beta_1800 on January 11, 2020, 04:20:40 AM



Title: Fuel draining back to tank
Post by: Aussie_Beta_1800 on January 11, 2020, 04:20:40 AM
Hi All,
I'm not sure if this is technically a 'problem' however it is quite annoying.
If my car sits for a day or so without being started, even overnight, the fuel drains back to the tank and takes about 10 cycles of the ignition to prime the system before I can attempt to start the car.
If the car sits for more than a week with no starting it takes significantly longer to prime the system.
My car has had a bunch of performance upgrades, guy croft manifold with twin 45 weber carbs, electric fuel pump connected just outside the tank.
Standard fuel tank and pick up.
There is no 'priming button' for the fuel pump, when the ignition is switched on it activates the pump for about 5 secs, so I have to constantly cycle ignition on and off to prime the fuel lines.
I bought the car with the upgrades completed so it's done it ever since I bought it but it doesn't seem normal to me to have to do this procedure every time the car has been sitting for a day or two.
Is this normal?
The fuel return line is still in use, is this a sign of a leak in the system somewhere or something else?
Please let me know if any further info is required

Car is an 1800 Beta coupe (1976)




Title: Re: Fuel draining back to tank
Post by: mangocrazy on January 11, 2020, 02:12:06 PM
What fuel pump are you using? When I converted to an electric pump (Huco) on my 2000 Spider, the instructions said to blank off the return line from the carb(s). That would seem to be a quick and simple way to ensure fuel doesn't drain back overnight. If that works successfully, you should also blank the return line off at the fuel tank.


Title: Re: Fuel draining back to tank
Post by: squiglyzigly on January 11, 2020, 04:49:52 PM
Slightly confused how fuel would drain back to the tank as the carb float chambers are below the float needle valve. Surely it’s not possible to ‘syphon’ the fuel out of the float bowls?
Is it possible something else is happening? Maybe the fuel is leaking within the carb? Or outside of the carb somehow? Just trying to look at it from a different angle?


Title: Re: Fuel draining back to tank
Post by: peteracs on January 11, 2020, 05:13:55 PM
I think you need to establish where there is fuel and where there is none after you leave it for a period. As mentioned above, hard to see how the float chamber is empty from the fuel lines, so maybe it is evaporation through poor seal etc?

Obviously there will be some evaporation via the jets as open to the atmosphere, but that much over a week sounds excessive.

Blocking the return line only makes sense if you can regulate the flow pressure via the pump and if needed a separate regulator.

Peter


Title: Re: Fuel draining back to tank
Post by: Neil-yaj396 on January 11, 2020, 08:09:00 PM
This only usually happens with a mechanical pump, especially if the diaphragm is perished. Surely the electric pump should kick in as soon as the ignition is switched on and prime the system?


Title: Re: Fuel draining back to tank
Post by: Aussie_Beta_1800 on January 13, 2020, 02:26:20 AM
Thanks for all the responses so far
There is no fuel in the fuel lines after sitting for a couple of days.
I can tell because 1) I've taken the line that feed fuel to the carbs and nothing there (until I cycle the ignition multiple times as per my original post)
and 2) the fuel pump is quite loud until the lines fill up with fuel

When switching the ignition on, the pump only runs for approx 5 seconds so not enough to prime the system, so it's a case of switching it on and off multiple times before fuel is in the lines and the engine can fire up.


Title: Re: Fuel draining back to tank
Post by: Neil-yaj396 on January 13, 2020, 08:32:50 AM
An electric pump should run as long as the ignition is on unless it is cut out by the inertia switch (if fitted).


Title: Re: Fuel draining back to tank
Post by: Aussie_Beta_1800 on January 13, 2020, 10:36:54 AM
An electric pump should run as long as the ignition is on unless it is cut out by the inertia switch (if fitted).

Excuse my ignorance and lack of knowledge, my last coupe had mechanical pump.
When I switch the ignition on, I can hear the pump run for a few seconds and then stop, I cycle the ignition a few times and the noise becomes noticeably quieter (I'm assuming this is because the lines are now primed ???)
If i try to start the car while the pump is still 'loud' all I get is spark and no fire.

Once the car is started it runs fine.


Title: Re: Fuel draining back to tank
Post by: rossocorsa on January 13, 2020, 08:37:58 PM
An electric pump should run as long as the ignition is on unless it is cut out by the inertia switch (if fitted).

I think most cars have some kind of shut off if the engine is not running


Title: Re: Fuel draining back to tank
Post by: Neil-yaj396 on January 14, 2020, 08:29:55 AM
This is a common problem with a mechanical pump but not an electric one. I know a few Fulvia owners who have fitted an electric pump specifically to prime the system. They then switch it off and revert to the mechanical pump once the car has fired up.

If Alan recons the pump is cutting out because the engine is failing to start quick enough, isn't that the actual problem rather than the pump? Weak spark etc.?


Title: Re: Fuel draining back to tank
Post by: monte on January 14, 2020, 07:28:13 PM
for what its worth, maybe no connection ,
I had fuel problems on a vx , fitted a facet electronic pump , silver top , with filter king pressure regulator ,no fuel to the carb until I removed the return flow pipe, however great difficulty to get it to prime if left sitting unused. fitted a non return valve next to the tank [best Chinese quality] still the same problem !
As you will know the facet pump is a piston pump driven by a spring and pulled back electrically ,considered ideal for carbs !!!
I have now gone to a standard rotary pump but retained the filter king and reconnected the flow return pipe, all seems to be well, however since its had no road miles since the jury is out.


Title: Re: Fuel draining back to tank
Post by: Aussie_Beta_1800 on January 15, 2020, 11:06:18 AM
This is a common problem with a mechanical pump but not an electric one. I know a few Fulvia owners who have fitted an electric pump specifically to prime the system. They then switch it off and revert to the mechanical pump once the car has fired up.

If Alan recons the pump is cutting out because the engine is failing to start quick enough, isn't that the actual problem rather than the pump? Weak spark etc.?
That's not the issue I'm having though I'm not trying to start the motor until it's primed, I'm simply switching the ignition to the on position so the pump powers up for a few seconds.
Once the fuel system is primed THEN I crank it over and the car starts straight away.


Title: Re: Fuel draining back to tank
Post by: Aussie_Beta_1800 on January 15, 2020, 11:12:45 AM
for what its worth, maybe no connection ,
I had fuel problems on a vx , fitted a facet electronic pump , silver top , with filter king pressure regulator ,no fuel to the carb until I removed the return flow pipe, however great difficulty to get it to prime if left sitting unused. fitted a non return valve next to the tank [best Chinese quality] still the same problem !
As you will know the facet pump is a piston pump driven by a spring and pulled back electrically ,considered ideal for carbs !!!
I have now gone to a standard rotary pump but retained the filter king and reconnected the flow return pipe, all seems to be well, however since its had no road miles since the jury is out.
It's the same electric pump fitted to my car so that's helpful to know - I think a solution could be to fit a separate priming switch for the pump to be used after it's sat for a few days, idea being it can power the pump until the system is fully primed, rather than only running for a couple of seconds each time the ignition is switched to the on position.
I'm still not sure that solves the issue of why there's no fuel in the lines after sitting


Title: Re: Fuel draining back to tank
Post by: Orbital on January 15, 2020, 11:16:41 AM
Aussie_Beta_1800 that sounds like a good solution to me.

George